Will you support Bootstrap 4?

When Bootstrap 4 is officially released we will begin the process of updating the themes. As of Feb 2016 there are 250 open issues for v4, so this may be sometime away, and it would be a bad decision to begin integrating Bootstrap 4 when so much could still change.

Can you tell me how to build some feature?

Unfortunately not, we just don't have the bandwidth to teach Rails to people over email.

Do the themes work with Turbolinks?

Yes. We have several customers using the themes with Turbolinks enabled. One note - you will need to make sure that all Javascript includes in the layouts are moved to the HEAD tag as Turbolinks throws away the contents of BODY and you will see strange behaviours. You'll also need to install jquery.turbolinks as Turbolinks breaks jQuery.

What license do I need?

Choose the right license level for your circumstance. If you're a night-time, side-project coder, then the Indie license is probably righ for you. If you're building lots of apps that need to look great, or one App with other developers then you're going to need a Pro license. If your churning out lots of prototypes for clients, then you're likely an Agency license. Any questions, just contact us.

Can I upgrade from one License to another?

Absolutely! Just send us your original receipt email and tell us you're upgrading and we'll apply what you've already paid to the new license level.

I get an error after running the customize generator.

If you're seeing something like this:

Invalid CSS after "  50": expected ")", was ":   hsl(351, 10…"

It's mostly likely because your sass and sass-rails are out of date. You should update to the latest versions in both cases and this will fix the issue

I get an SSL error when trying to bundle.

It's a sad fact, but sometimes the machine you are on will not have all of the latest Root CA certs, and you'll see SSL errors when trying to bundle install. If this happens, you can simply switch the gem source to use http instead of https.

If that doesn't fix the issue for you, email us with all of the following information when run in your terminal:

$ rvm -v
$ openssl version
$ uname -srv
$ ruby -v
$ bundler -v
$ gem -v
$ ruby -ropenssl -e 'puts OpenSSL::X509::DEFAULT_CERT_FILE'
$ openssl version -d
There's a bug in your Theme!

Bugs gonna happen! We're very sorry that you've run into trouble. Make sure to update the Theme to the latest version first by running bundle update dresssed-<uikit-name>. If that doesn't fix it, let us know.

On my production server, I get this error: dresssed.css isn't precompiled

First, make sure that in your Gemfile, gem 'dresssed-<theme-name>' is not inside the group :assets do block. Then, make sure require dresssed or require_tree . has been added to your application.css.

How do I change the logo in Gimlet?

In the file app/assets/stylesheets/dresssed.css or dresssed.css.less add the following code:

.navbar-brand {
  background-image: url('your_logo.png');
  width: 105px;
  height: 24px;
}

Or you can edit the original logo under psd/<style>/logo.psd and save it in app/assets/images/dresssed/<style>/logo.png.

If you don't have a logo yet and prefer to use text, add the following instead:

.navbar-brand {
  background-image: none;
  text-indent: 0;
  width: auto;
}
How do I unfix the navbar from the top?

Remove the navbar-fixed-top class on <div class="navbar"> and add the class static-navbar to your <body> tag.

Can I use your Theme with other Bootstrap gems?

Only if you make sure Bootstrap Javascript and CSS is not included by other gems. Our Themes contain their own version of Bootstrap. Including Bootstrap twice will cause an apocalypse.

Will your Theme support X?

If X requires any backend code (controller or model), then no. A theme only contains code to change and help you change the appearance of your app, not add features to it. If X is something that could be helpful in changing the appearance of an app and we don't support it, let us know.

Do you do custom Themes on demand?

Sorry, no.